SharePoint Rating System MOSS - NOT DEPLOYED

Feb 18, 2010 at 3:19 PM

Hi,

I'm getting error when I try to deploy "SharePoint Document Rating System MOSS ONLY Solution"

Albeit I successfully installed it in a Dev-environment, I'd like to move it to the Test-Environment with a load balancer and two F/E.
But the deployment fails with tthe error details below:

Name:

highlightmoss.wsp

Type:

Core Solution

Contains Web Application Resource:

Yes

Contains Global Assembly:

Yes

Contains Code Access Security Policy:

No

Deployment Server Type:

Front-end Web server

Deployment Status:

Error

Deployed To:

None

Last Operation Result:

The installation of features failed during deployment of the solution.

Last Operation Details:

MOSSQ01 : http://testrooms.company.net/ : The solution was successfully deployed.
MOSSQ02 : Feature '5daabc0d-5714-4b95-9238-95d58704bc11' could not be installed because the loading of event receiver assembly "HighLight, Version=1.0.0.0, Culture=neutral, PublicKeyToken=a020282aed59311d" failed: System.IO.FileNotFoundException: Could not load file or assembly 'HighLight, Version=1.0.0.0, Culture=neutral, PublicKeyToken=a020282aed59311d' or one of its dependencies. The system cannot find the file specified.
File name: 'HighLight, Version=1.0.0.0, Culture=neutral, PublicKeyToken=a020282aed59311d'
   at System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)
   at System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
   at System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
   at System.Reflection.Assembly.Load(String assemblyString)
   at Microsoft.SharePoint.Administration.SPFeatureDefinition.get_ReceiverObject()

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

MOSSQ01 : Feature '5daabc0d-5714-4b95-9238-95d58704bc11' could not be installed because the loading of event receiver assembly "HighLight, Version=1.0.0.0, Culture=neutral, PublicKeyToken=a020282aed59311d" failed: System.IO.FileNotFoundException: Could not load file or assembly 'HighLight, Version=1.0.0.0, Culture=neutral, PublicKeyToken=a020282aed59311d' or one of its dependencies. The system cannot find the file specified.
File name: 'HighLight, Version=1.0.0.0, Culture=neutral, PublicKeyToken=a020282aed59311d'
   at System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)
   at System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
   at System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
   at System.Reflection.Assembly.Load(String assemblyString)
   at Microsoft.SharePoint.Administration.SPFeatureDefinition.get_ReceiverObject()

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

 

I desperately hope that there is anyone who knows how to make this outstanding tool working as it does exactly what I was looking for.

Thx

Feb 19, 2010 at 10:39 AM

I could fix by Googling around. Just added the -force paramter and was good.
Stsadm –o deploysolution –name HighLightMOSS>wsp –allowgacdeployment –immediate –url http://testrooms.company.net –force )

Anyway, deployemnt worked but I didn't get the content type into sharepoint.

I'd expected the Rating System content Type....nothing there.  I openend a new thread as this is different.