This project is read-only.

Problem changing Content Type on existing items

Feb 15, 2010 at 2:57 PM

We have installed the MOSS version of the Rating System are trying to use it on an existing List which has over 700 items in it.  We are trying to Edit the list in Datasheet View in order to change the Content Type to the Item Rating content type, however, we are getting the following error:

Columns that require data are not included in this view.  If you want to edit rows that are missing data in these columns, or add new rows, you must first add the required columns to the view.

We have tried adding all the required columns to the view.  We have also tried changing all required columns to optional, but we are still getting this error when we try to change the Content Type.  What are we doing wrong?

 

Feb 25, 2010 at 5:45 AM

Hi,

So you probably have the exact same error message if you try to do something else than changing the content type, isn't it?

If you google a bit on your error message, you'll find thousands of results explaining you the possible causes.

Best Regards