Cannot activate Rating Solution Language files

Sep 29, 2009 at 10:11 AM

Hi all

First of all, thanks a lot for providing this solution. It's exactly that what I am needing for my project.

But I've got some issues with activating the Solution.
If I want to activate the "Rating Solution Language files" for the dedicated WebApp, I always get the "403 Forbidden" error.
The permissions tough, should be correct and also the solution is deployed correctly according to the "Operations" and "Solution Management".

I am working with the HighLightWSS.wsp solution file.

I am now quite long trying to activate the feature but until now, no success.

Can someone give me a tip how to solve that problem?

Thanks a lot for your help in advance.
Greetings

Coordinator
Oct 3, 2009 at 1:04 PM

Hi,

What the solution tries to do is to copy the .resx files into the IIS folder App_GlobalResources of the targetted web application on each WFE. It uses a timer job to make sure that the job gets executed by each WFE. As the timer job is executed by OWSTIMER, it might be that the identity running OWSTIMER isn't granted to write in the IIS folders.

In that case, I included an alternative described in the manual consisting in running stsadm -o copyappbincontent on each WFE server. That way, the .resx files will be copied. There are however two drawbacks :

1) The operation is manual and must be performed on each WFE by an administrator having access to a console.

2) The .resx files will be copied for ALL the web applications since you can't target a specific application with stsadm -o copyappbincontent

Hope this helps.

Best Regards

 

Oct 5, 2009 at 6:26 AM

Hello

Thanks a lot for your reply.

I have executed the command on the WFE server and tried to activate the solution afterwards. But unfortunately I still get the 403 Forbidden error.

Is there something else what I could try to do to get this solution activated?

Thanks a lot for your help in advance.

Best regards

J

Oct 9, 2009 at 7:10 PM

I installed the highlight.wss finishing up with the stsadm -o copyappbincontent command and saw all features in central admin with the exception of the tool basket language kit.  Uninstalled everything and went back through the steps installing the sharepointtoolbasket.wsp (never saw an updated sharepointtoolbasket_moss.wsp) but still do not see a sharepoint tool basket language file to activate.  any suggestions?