This project is read-only.

Bug in rated panel discussion from highlight.wsp

Mar 28, 2011 at 1:08 PM

Hi, I have installed a rated panel discussion.

I have a view of a panel discussion in my home page, that view has activated the response option. Pressing in response i get an error [Page not found]

[Good Link]http://pruebas.infocenter.es:8080/sector/fruta/Lists/fififi/NewForm.aspx?RootFolder=%2fsector%2ffruta%2fLists%2ffififi%2fvamos%20de%20paseo&ContentTypeId=0x0107&DiscussionParentID=1&Source=http%3A%2F%2Fpruebas%2Einfocenter%2Ees%3A8080%2Fsector%2Ffruta%2FLists%2Ffififi%2FFlat%2Easpx%3FRootFolder%3D%252fsector%252ffruta%252fLists%252ffififi%252fvamos%2520de%2520paseo%26FolderCTID%3D0x01200200202655C3C42C7F4E9A2560B179D4341A%26TopicsView%3Dhttp%253A%252F%252Fpruebas%252Einfocenter%252Ees%253A8080%252Fsector%252Ffruta%252Fdefault%252Easpx

[Bad link] http://pruebas.infocenter.es:8080/sector/fruta/Lists/fififi/NewForm.aspx&ContentTypeId=0x0107&DiscussionParentID=1?Source=http%3A%2F%2Fpruebas%2Einfocenter%2Ees%3A8080%2Fsector%2Ffruta%2FLists%2Ffififi%2Fvista1%2Easpx

¿Where is the part of the code that i have to change for solve this problem?

Thanks.

Mar 28, 2011 at 2:58 PM

Solution:

You must to change the first '&' by '?'.
 
Go to the route:
 
C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\TEMPLATE\FEATURES\Document Rating\RatingDiscussionList
open the file schema.xml.
 
Go to the line 214: and change  '&' by '?'.
<HTML><![CDATA[" ONCLICK="javascript:GoToPage(']]></HTML>
<ScriptQuote NotAddingQuote="TRUE">
<URL Cmd="New" />
</ScriptQuote>
<HTML><![CDATA[?ContentTypeId=0x0107&DiscussionParentID=]]></HTML>
<Field Name="ID" StripWS="TRUE" URLEncode="TRUE" />

That's all folks!