Disable Context menu "View Vote Report" in Document Rating for SharePoint 2007

Sep 30, 2010 at 8:30 PM

I have installed Document rating for SharePoint 2007 site. It works great (Thanks to Stephane). I would like to disable "View Vote Report" context menu on the document library. Is there any ways to do this? The reason is for users to be able to vote but not to see the report.

Thanks

Snehal H.Rana

Coordinator
Oct 1, 2010 at 5:52 AM

Hi Snehal,

The solution doesn't propose this...You can customize the solution & remove the functionality by:

 

- Setting the comment field to hidden

- removing the custom action from the ECB menu or trim it with a higher security permission level (managelist for instance)

 

Best Regards

 

Oct 5, 2010 at 7:52 PM

Hi Stephane,

How do I remove the custom action from the ECB menu or trim it with a higher security permissions level?

The goal is to have only administrators see the comments and not the users.

Thanks

Snehal

Coordinator
Oct 8, 2010 at 8:12 AM

Hi,

Yes, you can customize the solution and elevate the value of the "Rights" attribute that's already declared at the custom action level. You can for instance use "ManageLists" so that list managers are able to view reports.

Best Regards

Oct 8, 2010 at 9:06 PM

Hi Stephane,

I found the location of customactions..xml. It is located at 12 hive under \TEMPLATE\FEATURES\Document Rating But the issue is that there are more than 1 section in this file under. Which section will need to be modified to be able to hide the "View Vote Report" Custom action menu?

Thanks

Snehal

Oct 11, 2010 at 5:20 PM

I tried changing the permissions to ManageWeb and it completely took off the Vote functionality from the users view. I need for them to be able to Vote. Will changing this to ManageLists work?

Oct 11, 2010 at 5:42 PM

Found the solution!!

Nov 24, 2010 at 7:49 PM

Hi Stephane,

I got this to work for a while, but lost it again. Any idea how do I get this to work? I had made some changes to customactions.xml but they are all gone. What rights I need to set to make this work.

Please help

Thanks

Snehal

Nov 24, 2010 at 8:03 PM

Just fixed it again. I made some changes in the customactions.xml and it worked!!